Beam web wallet compatability with firefox

At the moment the beam web wallet is only available for Chrome. It would be great if it were available for other web browsers such as Firefox. Firefox is much more privacy oriented as well.

Yeah this surprised me. It should have been built on firefox first. But only works in chromium lol. So strange.

Idk

2 Likes